Mainos / Advertisement:

RouterOS Qos

From Taisto
Jump to navigation Jump to search

RouterOS:llä Qos eli kaistanleveydenhallinta ja priorisoinnit on mahdollista Queuen ja Mangle sääntöjen avulla.

Voit rajoittaa kaistaa protokola ja IP-pohjaisesti. Esimerkiksi voit rajoittaa Youtubeen menevää kaistaa tai priorisoida http / https protokolat korkeimmilleen verraten P2P yhteyksiin (kuten torrent). Priorisoinnilla saadaan jokaiselle toimimaan perusyhteys hitaammallakin laajakaistalla.

Qos ominaisuus vie reitittimestä jonkin verran tehoa joten suositeltavaa olla aika tehokas laite tätä käyttäessä.

Mangle säännöt

Lisää Mangle säännöt IP -> Firewall -> Mangle

 /ip firewall mangle

Esimerkkisääntöjä joita voit lisätä:

add action=mark-packet chain=forward new-packet-mark=icmp passthrough=no protocol=icmp
add action=mark-packet chain=forward dst-port=80 new-packet-mark=http passthrough=no protocol=tcp
add action=mark-packet chain=forward dst-port=443 new-packet-mark=https passthrough=no protocol=tcp
add action=mark-packet chain=forward new-packet-mark=p2p p2p=all-p2p passthrough=no
add action=mark-packet chain=forward new-packet-mark=udp-100 packet-size=0-100 passthrough=no protocol=udp
add action=mark-packet chain=forward new-packet-mark=upd-500 packet-size=100-500 passthrough=no protocol=udp
add action=mark-packet chain=forward new-packet-mark=upd-other passthrough=no protocol=udp
add action=mark-packet chain=forward dst-port=110 new-packet-mark=pop3 passthrough=no protocol=tcp
add action=mark-packet chain=forward dst-port=25 new-packet-mark=smtp passthrough=no protocol=tcp
add action=mark-packet chain=forward dst-port=143 new-packet-mark=imap passthrough=no protocol=tcp
add action=mark-packet chain=forward new-packet-mark=gre passthrough=no protocol=gre
add action=mark-packet chain=forward new-packet-mark=ipsec-esp passthrough=no protocol=ipsec-esp
add action=mark-packet chain=forward new-packet-mark=ipsec-ah passthrough=no protocol=ipsec-ah
add action=mark-packet chain=forward new-packet-mark=ipencap passthrough=no protocol=ipencap
add action=mark-packet chain=forward new-packet-mark=ipip passthrough=no protocol=ipip
add action=mark-packet chain=forward connection-bytes=1-512000 new-packet-mark=0bytes passthrough=yes
add action=mark-packet chain=forward connection-bytes=512000-1000000 new-packet-mark=1Mbyte passthrough=yes
add action=mark-packet chain=forward connection-bytes=1000000-3000000 new-packet-mark=3Mbyte passthrough=yes
add action=mark-packet chain=forward connection-bytes=3000000-6000000 new-packet-mark=6Mbyte passthrough=yes
add action=mark-packet chain=forward connection-bytes=6000000-30000000 new-packet-mark=30Mbyte passthrough=yes
add action=mark-packet chain=forward connection-bytes=30000000-60000000 new-packet-mark=60Mbytes passthrough=yes
add action=mark-packet chain=forward connection-bytes=60000000-0 new-packet-mark=Infinite passthrough=yes

Queue Tree

Lisätään Queue Tree

/queue tree
add limit-at=550000000 max-limit=550000000 name=OVERALL parent=INTERNAL priority=5

add name=PRIO1 parent=OVERALL priority=1
	add name=0-512 packet-mark=0bytes parent=PRIO1 priority=1
	add name=ICMP packet-mark=icmp parent=PRIO1 priority=1
	add name=POP3 packet-mark=pop3 parent=PRIO1 priority=1
	add name=SMTP packet-mark=smtp parent=PRIO1 priority=1
	add name=IMAP packet-mark=imap parent=PRIO1 priority=1
	add name=HTTP packet-mark=http parent=PRIO1 priority=1
	add name=HTTPS packet-mark=https parent=PRIO1 priority=1
	add name=MSN-MESSENGER packet-mark=msn-messenger parent=PRIO1 priority=1

add name=PRIO3 parent=OVERALL priority=3
	add name=1Mbyte packet-mark=1Mbyte parent=PRIO3 priority=3

add name=PRIO4 parent=OVERALL priority=4
	add name=3Mbyte packet-mark=3Mbyte parent=PRIO4 priority=4

add name=PRIO5 parent=OVERALL priority=5
	add name=6Mbyte packet-mark=6Mbyte parent=PRIO5 priority=5

add name=PRIO6 parent=OVERALL priority=6
	add name=30Mbyte packet-mark=30Mbyte parent=PRIO6 priority=6

add name=PRIO7 parent=OVERALL priority=7
	add name=60Mbyte packet-mark=60Mbytes parent=PRIO7 priority=7

add name=PRIO8 parent=OVERALL priority=8
	add name=Infinite packet-mark=Infinite parent=PRIO8 priority=8
	add name=GRE packet-mark=gre parent=PRIO8 priority=8
	add name=IPSEC-ESP packet-mark=ipsec-esp parent=PRIO8 priority=8
	add name=IPSEC-AH packet-mark=ipsec-ah parent=PRIO8 priority=8
	add name=P2P packet-mark=p2p parent=PRIO8 priority=8
	add name=IPENCAP packet-mark=ipencap parent=PRIO8 priority=8
	add name=IPIP packet-mark=ipip parent=PRIO8 priority=8

add name=UDP parent=OVERALL priority=1
	add name=UDP-100 packet-mark=udp-100 parent=UDP priority=1
	add name=UDP-500 packet-mark=upd-500 parent=UDP priority=3
	add name=UDP-Other packet-mark=upd-other parent=UDP priority=8

Lähde: http://wiki.mikrotik.com/wiki/Traffic_Priortization,_RouterOS_QoS_Implemetation

Mainos / Advertisement: