Mainos / Advertisement:

Cisco Catalyst C2620 reititin

Kohteesta Taisto
Loikkaa: valikkoon, hakuun
Tämä sivu sisältää muutoksia, joita ei ole merkitty käännettäväksi.

Muut kielet:
suomi

Ciscon reitittimessä peruskomennot on samanlaiset kuin kytkimissäkin. Huomaathan, että reitittimessä kaikki ethernetportit ovat alhaalla.

Cisco reitittimen peruskäyttö: Cisco_IOS_peruskäyttö

DHCP

Luodaan DHCP pool:

 Router(config)# ip dhcp pool XXX 

XXX = DHCP Poolin nimi

Määritetään verkko-osoite ja aliverkonpeite:

 Router(dhcp-config)# network 10.0.0.0 255.255.255.0

Määritetään domain name joka jaetaan:

 Router(dhcp-config)# domain-name example.com

Määirtetään DNS palvelin joka jaetaan:

 Router(dhcp-config)#dns-server 8.8.8.8 8.8.4.4

Määritetään oletusyhdyskäytävä:

 Router(dhcp-config)# default-route 10.0.0.1

Määritetään lease time (eli kuinka kauan pidetään IP-osoite varattuna). Oletuksena tämä on yksi päivä. Infinite on ääretön.

 Router(dhcp-config)# lease {days [hours]  [minutes] | infinite }

Ei jaettavat osoitteet

Oletuksena Ciscon DHCP palvelu jakaa kaikki verkossa olevat IP-osoitteet, esimerkiksi testiverkossamme 10.0.0.0/24 verkossa jaetaan kaikki 10.0.0.1 - 254 IP-osoitteet, lukuunottamatta oletusyhdyskäytävää.

Voit rajoittaa IP-osoitteiden jakoa:

 ip dhcp excluded-address 10.0.0.250

Rajoita 10.0.0.200 osoitteesta 10.0.0.220. Näitä siis ei jaeta DHCP:n kautta.

 ip dhcp excluded-address 10.0.0.200 10.0.0.220

Ali interface

Ota pää interface käyttöön (enable)

 interface fastethernet 0/0
 no shutdown


Määritetään ali interface (2 = esimerkiksi VLANin numero)

 interface fastethernet 0/0.2

Määritä seuraavaksi numero 2 on VLANin numero!

 encapsulation dot1q 2 

Määritetään toinen ali interface VLAN 3:

 interface fastethernet 0/0.3
 encapsulation dot1q 3

Reititys

Reititys komento toimii kahdella tavalla:

IP-osoite reitittimeen (192.168.1.1)

 Router(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.1 

tai verkkoliitäntänä

 Router(config)# ip route 0.0.0.0 0.0.0.0 fastethernet0/1


NAT - Osoitemuutos

Määritetään sisäverkon portit, esimerkiksi fastethernet 0/0 ja 0/0.1 .

 interface fastethernet 0/0
 ip nat inside
 interface fastethernet 0/0.1
 ip nat inside
 

jne...

Määritetään ulkoverkon portti, esimerkiksi fastethernet 0/1.

 interface fastethernet 0/1
 ip nat outside

Pääsylistat, esim. sallitaan kaikki:

 access-list 1 permit any

Lopuksi:

 ip nat inside source list 1 interface fastethernet 0/1

ip nat = Tehdään IP-osoitteen muutos

inside = Kaikissa sisäverkon porteissa jotka on määritetty inside verkoksi

source list 1 = Tehdään pääsylista (access-list) 1:n mukaan

interface fastethernet 0/1 = annetaan paketeille ko. interfacesin osoite

Staattinen NAT. Julkinen osoite on aina sama, 209.165.200.227:

 ip nat inside source static 192.168.1.10 209.165.200.227

Näytä osoitemuutos:

 Router# show ip nat translations

Radius

Esimerkki konfiguraatio. Luodaan ensin ryhmä krbradius ja määritetään sille Radius palvelimen osoite 192.168.10.10. Lisätään varmuuden vuoksi paikallinen käyttäjätunnus admin ja salasanaksi Qwerty123 jos ei radius toimi niin pääsee sisälle. Key Qwerty123 on Radius palvelimeen määritetty avain.

aaa new-model
aaa group server radius krbradius
server 192.168.10.10 auth-port 1812 acct-port 1813
!
aaa authenticartion login default local group krbradius
!
username admin password 0 Qwerty123
!
radius-server host 192.168.10.10 auth-port 1812 acct-port 1213 key Qwerty123

Telnet Radius

line vty 0 4
login authentication default
aaa authentication login default line
enable secret Qwerty123 
Mainos / Advertisement: