Mainos / Advertisement:

Cisco IOS peruskäyttö

Kohteesta Taisto
Loikkaa: valikkoon, hakuun
Tämä sivu sisältää muutoksia, joita ei ole merkitty käännettäväksi.

Muut kielet:
English • ‎suomi

Ciscon IOS Ciscon reitittimissä ja kytkimissä oleva käyttöjärjestelmä. Molemmissa käytetään hierarkista rakennetta.

Kuva Ciscon Netacad: Ciscon IOS Hierarkian rakenne

Peruskäyttö

Cisco IOS saat aina apua laittamalla komennon perälle "?". Seuraava komento esimerkiksi listaa kaikki komennot User tilasta.

Switch> ?

Tabulaattorilla Linuxin tapaan auto kirjoittaa komennon tai ehdottaa komentoja. Ciscossa voi käyttää lyhenteitä myös (esimerkissä komento copy running-config startup-config):

 copy start run 

Komentojono on valmis niin näkyy alla oleva merkintä.

<cr>

Komentojonosta puuttuu tietoja näkyy seuraava virheilmoitus. Käytä tällöin "?" ja tabulaattoria.

 % Incomplete command

Komentojono on virheellinen tai kirjoitusvirhe:

 % Invalid input detected at '^' marker

Poistu / sulje

 exit

User -tila

Kytkin/reititin käynnistyy normaalisti tähän tilaan. Tässä tilassa ei voi tehdä oikein mitään, joten siirrytään Priviledge-tilaan.

Tässä tilassa voit esimerkiksi pingata ja näyttää jotakin rajoitetusti.

Switch> ping 8.8.8.8

Priviledge -tila

Priviledge -tilaan pääset komennolla

Switch> enable

Kytkin/reititin kysyy salasanaa, mikäli sellainen on määritetty.

Priviledge tilassa voit selata nykyistä konfiguraatiota

Switch# show running-config

Sekä nykyisiä VLANeja

Switch# show vlan

Voit kopioida pyörivän konfiguraation käynnistyskonfiguraatioon (ns. tallentaminen)

Switch# copy running-config startup-config

Tallentaminen onnistuu myös seuraavalla komennolla (toimii myös HP:ssa)

Switch# write memory

Poista konfigurointitiedostot

 Switch# erase startup-config

Ja käynnistä uudelleen.

Näytä verkkosovittimet

 Switch# show interface

Näytä IP-osoitteet

 Switch# show ip interface

Näytä reititys (Layer 3 kytkin ja reititin)

  Router# show ip route

Näytä ARP - taulu

 Switch# show arp

Näytä firmwaren versio

 Switch# show version


Konfiguraation varmuuskopiointi ja palautus

Varmuuskopioitaessa ja palauttaessa sinulla tulee olla TFP palvelin.

Kopioi varmuuskopioitavan käynnistys konfiguraatiot TFTP:llä tietokoneelle. Voit myös kopioida konfiguraatiot txt tiedostoon kun tulostat show running-config komennolla.

 copy startup-config tftp

Tämän jälkeen kysytään:

  • Verkko-osoitetta tai IP-osoitetta TFTP palvelimeen
  • Tiedoston nimi jolle tallennetaan konfigurointi tiedosto
  • Vahvista tallennus

palauta TFTP:llä

 copy tftp running-config
  • Verkko-osoitetta tai IP-osoitetta TFTP palvelimeen
  • Tiedoston nimi josta palautetaan konfiguraatio
  • Vahvista palautus

Tallenna running-config käynnistys konfiguraatioon jos haluat että palautettava ladataan uudelleen käynnistyessä.

Konfiguraation automaattinen varmuuskopiointi

Tässä esimerkki konfiguraatio jolla määrität varmuuskopioinnin joka 60min välein

Router#conf t
Router(config)#archive
Router(config-archive)#path tftp://ip-address/file-name.txt
Router(config-archive)#time-period 60
Router(config-archive)#do write memory

Flash formatointi

Ennen kuin voit käyttää Flashiä se pitää formatoida. Ciscon laitteet voivat olla nihkeitä Flash muisteista joten varmista tuki.

Käynnistä Ciscon reititin Priviledge tilaan. Formatoi flash seuraavalla komennolla.

 format flash:

Configure -tila

Configure -tilaan pääset komennolla

Switch# configure terminal

Configure -tilassa tehdään kytkimen konfiguraatiot (no shit sherlock :D - Copyright: Aleksi).

Hostnamen määrittäminen

Isäntänimen määrität helposti seuraavalla komennolla

 Router(config)# hostname router

Salasanat

Suojaa kytkin asettamalla salasanoja.

Konsoliyhteys

Suosittelemme määrittämään konsoliyhteydelle salasanan

 Switch(config)# console 0
 password [salasana]
 login

Telnet

Telnet yhteydellä voit muokata kytkimen/reitittimen asetuksia ilman, että sinun täytyy olla yhteydessä konsolikaapelilla. Telnet -yhteys on oletuksena poissa käytöstä. Sinun täytyy määrittää kytkimelle ensin IP-osoite.

 Switch(config)# line vty 0 [1-15]

0-15 määrittää kuinka monta samanaikaisia yhteyksiä sallitaan. 0 = 1 yhteys kerrallaan, 2 = 3 yhteyttä kerrallaan, jne.

Suositus on suojata telnet yhteys salasanalla, koska muuten kuka tahansa pääsee käsiksi konfigurointitiedostoihin.

 password [salasana]

Ja kirjautuminen päälle

 login

Enable salasana

 Switch(config)# enable password [salasana] (ei suositella)
 Switch(config)# enable secret [salasana] (suositus)


Nyt sinun täytyy antaa salasana, kun muodostat yhteyden konsoliyhteydellä.

Kryptaa kaikki salasanat

Tämä kryptaa salasanat jotta niitä ei näy selväkielisinä show running-config komennolla

 Switch(config)# service password-encryption

Bannerit

Banneri näytetään ennen kirjautumista.

 Switch(config)# banner motd #This is secure system! Authorized Access ONLY!!!!#

Interface

Kaikki yhteydet yhdistyvät kytkimissä, joten kaikkia yhteyksiä määritetään interface -komennolla.

Muuta yhden portin asetuksia kytkimessä:

 Switch(config)# interface FastEthernet 0/1
 Switch(config)# interface GigabitEthernet   1/1

Muuta useamman portin asetuksia:

 Switch(config)# interface range FastEthernet 0/1 - 20
 Switch(config)# interface GigabitEthernet 1/1 - 2

Kuvaus

Voit antaa verkkoliitännän kuvauksen

 Switch(config)# interface FastEthernet 0/1
 description connection to Admin LAN
 exit

Esimerkiksi kuvauksena yhdistäminen ylläpitäjien verkkoon

IP-osoite

Valitse interface esimerkiksi FastEthernet 0/1 tai interface alue (range)

 Switch(config)# interface FastEthernet 0/1
 ip address 10.0.0.1 255.255.255.0
 exit

VLAN

Määritetään interface / interfacet tietyyn VLANiin, esimerkiksi VLAN2. Oletuksena kaikki interface ovat VLAN1.

 Switch(config)# interface FastEthernet 0/1
 swicthport mode access
 switchport access vlan 2
 exit

Nyt interface FastEthernet on Vlan 2 ja muut interfacet ovat VLAN1.

DNS

Määritetään mitä nimipalvelimia Cisco käyttää.

 ip name-server 8.8.8.8 8.8.4.4

Kokeile sitten do ping www.google.com

VLAN

Oletuksena kytkimessä on yksi VLAN numerolla 1 (VLAN1)

Määritetään VLAN1 IP-osoite ja aliverkonpeite

 Switch(config)# interface vlan 1
 ip address 10.10.10.100 255.255.255.0
 no shutdown

Nyt on määritetty VLAN 1 IP-osoite 10.10.10.100 ja 255.255.255.0. Oletuksena kaikki portit kuuluvat VLAN 1.

Lisätään uusi VLAN

 Switch(config)# interface vlan 2
 ip address 192.168.1.200 255.255.255.0
 no shutdown

Määritetään tietyt portit VLAN 1 ja osa VLAN 2. Esimerkiksi FastEthernet 1 - 12 VLAN 1 ja FastEthernet 13 - 24 VLAN 2

 Switch(config)# interface range fastethernet 0/1 - 2
 switchport mode access
 switchport access vlan 1
 interface range fastethernet 0/13 - 24
 switchport mode access
 switchport access vlan 2

Native VLANin vaihto

Cisco käyttää natiivi VLANia 1:stä. Tätä VLANia ei yleensä käytetä siksi mihinkään.

Esimerkissä vaihdetaan Natiivista VLANia 1 -> 222.

  interface fastethernet 0/22
  switchport trunk native vlan 222

Port Security

Portti suojaus voidaan toteuttaa komella eri tavalla: Static, Dynamic ja Sticky.

Staattiseen määritetään yksi MAC osoite liitännälle. Vain tällä MAC-osoitteella pystyy käyttämään kyseistä liitäntää.

Dynaaminen toimii MAC taulun mukaisesti.

Sticky muistaa määritetyn määrän MAC-osoitteita jotka sallitaan käyttää liitäntää.

Static Port Security

Valitaan ensin portti / porttialue

 Switch(config)# interface fastEthernet 0/11

Muutetaan sovittimen tilaa access. Oletustilassa ei pysty määrittämään portti suojauksia.

 Switch(config)# switchport mode access

Otetaan portti suojaus käyttöön

 Switch(config)# switchport port-security mac-address mac-address [vlan {vlan-id | {access | voice}]

Dynamic Port Security

Valitaan ensin portti / porttialue

 Switch(config)# interface fastEthernet 0/11

Muutetaan sovittimen tilaa access. Oletustilassa ei pysty määrittämään portti suojauksia.

 Switch(config)# switchport mode access

Otetaan portti suojaus käyttöön

 Switch(config)# switchport port-security 

Sticky Port Security

 Valitaan ensin portti / porttialue
 Switch(config)# interface fastEthernet 0/11

Muutetaan sovittimen tilaa access. Oletustilassa ei pysty määrittämään portti suojauksia.

 Switch(config)# switchport mode access

Otetaan portti suojaus käyttöön

 Switch(config)# switchport port-security 

Määritetään enimmäismäärä turvallisia osoitteita

 Switch(config)# switchport port-security maxium 50

Otetaan Sticky oppiminen

 Switch(config)# switchport port-security mac-address sticky

Rommon -tila

Rommon tilassa voit asentaa uuden iOSsin Ciscon reitittimiin

IOS lataus TFTP palvelimelta

Määritä ensin ympäristömuuttujat SET komennolla.

rommon 3 > set 
    PS1=rommon ! > 
    IP_ADDRESS=172.18.16.76 
    IP_SUBNET_MASK=255.255.255.192 
    DEFAULT_GATEWAY=172.18.16.65 
    TFTP_SERVER=172.18.16.2 
    TFTP_FILE=quake/rel22_Jan_16/c2600-i-mz

Käynnistä TFTP komennolla

 tftpdnld

ja vahvista asetukset.


Salasanan resetointi tai tehdaasetusten palautus

Voit resetoida hallinnan salasanan rommon modesta käsin estämällä lataamalla konfiguraatiota.

1. Sammuta reititin / kytkin

2. Käynnistä reititin / kytkin rommon modeen. Esimerkiksi puttyllä käytä Special command: break toimintoa kun laite käynnistyy. Reitittimissä poista flash muisti.

3. Aja komento muuttamalla rekisteri arvoa. Tämä estää konfiguroinnin latauksen bootissa.

rommon 1 > confreg 0x2142

4. Seuraavaksi käynnistä laite uudelleen

rommon 1 > reset

Varmista että flash on nyt sisällä :)

5. Kun reititin / kytkin on käynnistynyt vastaa ensimmäiseen setup kysymykseen "no"

6. Kirjoita eneable ja konfiguroi muisti kopioimalla käynnistyskonfiguraatio nyt ajettavaan konfiguraatioon.

 copy startup-config running-config
  • #HUOM! Älä aja copy running-config startup-config tai write memory koska tämä poistaa käynnistyskonfiguraation ellet halua resetoida laitetta tehdasasetuksille

Jos halusit resetoida kaikki konffit, käynnistä laitteesi vain uudelleen tyhjentääksesi kaikki

7. Muuten mene configure terminal ja määritä uusi salasana

 hostname(config)#enable secret cisco

8. Konfiguroi rekisteriarvoksi

 hostname(config)#config-register 0x2102

9. Tallenna konffit :)

Mainos / Advertisement: