Mainos / Advertisement:

RouterOS WLAN

Kohteesta Taisto
Loikkaa: valikkoon, hakuun
Tämä sivu sisältää muutoksia, joita ei ole merkitty käännettäväksi.

Muut kielet:
suomi

RouterOS:ssä on langattoman verkon tuki. Ohjeessa tutustumme langattoman verkon asetuksiin. Varmista että laitteistossasi on tuettu WLAn kortti.

RouterOS langaton noudattaa IEE802.11 standardia ja on tukee 802.11a, b, g, n ja lisäominaisuuksia WPA, WEP, AES salaus, WDS, DFS, Virtual Access Point, Nstreme ja NV2 protokolaa.

WLAN pystyy toimimaan monessa eri tilassa: client (statioN), access point (ap-bridge), wireless bridge jne..

Interface

Tutustutaan langattoman verkon perusasetuksiin interfacen osalta

General

General välilehdessä voit määrittää WLAN AP:lle:

  • Nimen, ei sama kuin SSID, voi olla mikä tahansa
  • MAC-osoitteen. Varmista että on eri kuin muiden interfacen.
  • MTU
  • ARP

RouterOS WLAN interface general 1.png

Wireless

Wireless välilehdessä tehdään peruskonfiguraatiot. Advance Mode:ssa on lisäasetuksia. Tässä manuaalissa ei ole listattu kaikkia ominaisuuksia, kaikki löytyy RouterOS:n dokumentaatiosta.

  • Mode: Valitse tila jota käytetään.
    • station - WLAN Client, eli voit yhdistää toiseen tukiasemaan.
    • station-wds - Sama kuin station mutta luo wds sillan, eli toimii toistimena ja clienttina
    • ap bridge - vastaa normaalia WLAN tukiasemaa.
    • bridge - Sama kuin ap-bridge, mutta sallii vain yhdistetyn clientin kerrallaan.
    • aligment only - Sama kuin ap-bridge, mutta sallii vain yhden yhdistyneen clientin (asiakkaan) kerrallaan.
    • nstreme-dual-slave - Sallii interfacen olevan nstreme-dual kokoonpano käytössä
    • wds-slave - Sama kuin ap-bridge, mutta scannaa ap:ta samalla ssid ja nostaa ylös wds-linkin. Jos linkki katoaa ulottuvilta, jatkaa scannausta.
    • station-pseudobridge - Sama kuin station, mutta lisää mac-osoite muuntamisen kaikkeen liikenteeseen
    • station-pseudobridge-clone - Sama kuinstation-pseudobridge, mutta käyttää station-bridge-clone-mac osoitetta yhdistääkseen access-pointtiin.
    • station-bridge - Tässä tilassa ap ylläpitää edelleenlähetettävää taulua mac-osoitteista jotka ovat saatavilla clienttien kautta ym.
  • Band: Määrittää siirtonopeuden, kanava ja kaistanleveyden.
  • Channel Width: Määritä laajennettu kanava.
  • Frequency: Langattoman verkon kanava. Oletus: auto
  • SSID: SSID (Service Set Identifier) on nimi jolla tunnistetaan langaton verkko.
  • Wireless Protocol:Langattoman verkon protokola. Yleisin käytössä oleva protokola on 802.11
  • Security Profile: Määritä tähän turvallisuus profiili.
  • Bridged Mode: Sallii station-bridge tilan.
  • Default AP TX Rate: Rajoita langattoman verkon lataus nopeutta. Esim 10M = 10Mbps
  • Hidden SSID - Tukiasema ei lähetä SSID:tä.
 /interface wireless

RouterOS WLAN interface wireless 1.png

Advance Modesta:

  • Frequency Mode - Määritä miten maa-asetuksia noudatetaan. Noudata maakohtaisia asetuksia!
    • regulatory-domain - Rajoita saatavilla olevat taajuudet ja maksimilähetystehon jokaisessa kanavassa sallitun mukaisesti (valtiossa)
    • manual-txpower - Sama kuin aikaisemmin, mutta ei rajoita maksimilähetystehoja
    • superchannel - Testausta varten. Kaikki tuetut kanavavat langattomassa kortissa on käytettävissä.
  • Country: Rajoita sallittuja langattomia taajuuksia, kaistaa, maksimitehoja.

RouterOS WLAN interface wireless 2.png

Tx Power

Tx Power välilehdessä voit määrittää lähetystehon manuaalisesti. Huomioi maakohtaiset lait! Suomessa maksimilähetysteho on 100mW!

/interface wireless manual-tx-power-table

  • Tx Power Mode
    • all rates fixed: Käyttää samaa lähetystehoa kaikille data arvoille.
    • Default: Oletus. Oletuksena ilman maa-asetuksia on maksimitehoilla.
    • Card rates: Käyttää niitä lähetystehoja jotka on määritetty on Tx power asetuksista.
    • manual: Määritä arvot manuaalisesti

Esimerkkejä arvoista:

Power (mW) Power (dBm)
10 10
100 20
1000 30

Security Profiles

 /interface wireless security-profiles

RouterOS WLAN security profiles wpa 1.png


Turvallisuus profiileihin määritetään langattoman verkon suojauksia.

Perusominaisuudet

  • Mode: Langattoman verkon salauksen tila
    • static-keys-required / static-keys-optional - WEP tila, ei suositella.
    • dynamic-keys - WPA - tila (suositus)

WPA / WPA2 Personal

  • authentication-type: Todennustyypit. Valitse todennustapa mitä asiakkaat voivat käyttää.
  • unicast-ciphers: Tukiasema mainostaa tätä salaustapaa. Asiakas yrittää ottaa yhteyttä tukiasemaan jos tukee jotakin määrättyä salausta. Voit valita useita vaihtoehtoja.
  • group-ciphers: Tukiasema mainostaa näitä ja käyttää salatakseen broadcast ja unicast framet. Asiakas ottaa yhteyttä tukiasemaan, joka käyttää jotakin määrättyä salausta. Voit valita useita vaihtoehtoja.
    • TKIP -Temporal Key Integrity Protocol: Salausprotokola joka on yhteensopiva WEP laitteiden kanssa.
    • AES - Advanced Encryption Standard: parempi salausprotokola. Suosittelemme!
  • wpa-pre-shared-key, wpa2-pre-shared-key :WPA ja WPA2 ennalta jaettu avain on laitteiden yhteyden salausavain. Voit määrittää salausavaimeksi minkä haluat. Suosittelemme yli 8 merkkistä salausavainta.

WPA / WPA2 EAP

EAP mahdollistaa todennuksen radius palvelimen tai sertifikaatin avulla. Valitse authentication-type WPA-EAP ja/tai WPA2-EAP ja siirry EAP välilehdelle.

  • eap-methods: EAP-TLS todennuksessa käytetään asiakas ja palvelin sertifikaattia
  • passthrough : Tukiasema välittää todennusprosessin radiukseen.

Radius ohje: https://www.taisto.org/RouterOS#Radius_Client

Reperter - toistin

Mikrotik voi käyttää myös toistimena ja sen saa helposti määritettyä päälle.

Esimerkkikonffi:

  • SSID on se WLANin SSID jonne yhdistetään
  • Security profiili on WLANin profiili johon yhdistetään eli sen kirjautumistunnukset
 /interface wireless set number=0 mode=station-pseudobridge ssid=WLAN frequency=auto security-profile=wlan1
 /interface wireless add name=wlan1-sec mode=dynamic-keys authentication-types=wpa2-psk unicast-cipher=aes-ccm wpa2-pre-shared-key=XXXXX

Lisää sitten virtuaali AP joka voi olla samalla nimellä kuin alkuperäinen master tukiaseman nimi tai joku muu.

Lähteet

http://wiki.mikrotik.com/wiki/Manual:Interface/Wireless

http://wiki.mikrotik.com/wiki/Manual:Wireless_Station_Modes

http://wiki.mikrotik.com/wiki/Wireless_Matrix

http://wiki.mikrotik.com/wiki/Manual:Wireless_Station_Modes

Mainos / Advertisement: