Mainos / Advertisement:

RouterOS VPN PIA

From Taisto
Jump to navigation Jump to search

Tässä erillinen ohje kuinka otetaan RouterOS:llä Privateinternetaccess VPN käyttöön. PIA tukee OpenVPN, PPTP ja L2TP/IPSec protokolia. RouterOS:llä ei voi käyttää OpenVPN protokolaa mutta suosittelemme käyttämään L2TP/IPSec protokolaa.

1. Tilaa PIA:n sivuilta palvelu käyttöösi ensin: https://www.privateinternetaccess.com/

2. Kun tilaus suoritettu ja olet päässyt PIA:n yhallintaan luo hallintakonsolin alaosassa käyttäjätili PPTP/L2TP yhteyksille. Tunnus on sama kuin sait sähköpostiin mutta tunnus eri. Tätä tunnusta käytetään Mikrotikissä.

3. Konfiguroi Mikrotik aloittamalla luomalla uusi L2TP client. Käyttäjätunnus ja salasana ovat hallintapaneelissa jotka olet luonut.

  /interface l2tp-client add connect-to="fi.privateinterneraccess.com" user=XXX password=XXX ipsec-secret=mysafety


RoS PIA setup-1.PNG

4. Kun Status muuttuu Connected on Mikrotikkisi yhteydessä Suomen PIA:n palvelimeen.

5. Luo src-nat (source-nat) tähän L2TP interfaceen

 /ip firewall nat add chain=srcnat out-interface=l2tp-pia  action=masquerade

6. Tee Mangle että sisäverkon osoitteet merkitään

 /ip firewall mangle add src-address=192.168.88.0/24 action=mark-routing new-routing-mark=to-pia

7. Luo reititys että kaikki 192.168.88.0/24 laitteista lähtevä liikenne menee PIA:n kautta

 /ip route add dst-address=0.0.0.0/0 gateway=l2tp-pia routing-mark=to-pia

8. Testaa yhteyden toiminta.

Mainos / Advertisement: