Mainos / Advertisement:

RouterOS VLAN

Kohteesta Taisto
Loikkaa: valikkoon, hakuun
Muut kielet:
suomi


RouterOS tukee useiden VLAN (Virtual Local Area Network / Virtual LAN, virtuaaliverkot). Tämä mahdollistaa jakaa esimerkiksi yrityksessä osatsto omiin verkkoihin riippumatta miten osastot on jaoteltu rakennuksessa. VLAN vaatii tuen kytkimiltä ja reitittimiltä.

VLANeihin tukevat laitteet liittävät lähettämiinsä paketteihin tunnuksen, jonka avulla vastaanottava laite tietää mihin verkkoon paketti kuuluu. Kun paketti lähetetään eteenpäin laitteelle joka ei tue VLANeja, tunnus poistuu,

 /interface vlan

Esimerkki

Lisätään VLAN 10 interfaceen bridge-local. Suosittelemme laittamaan aina vlanit bridgeen sillä bridge ei mene koskaan alas vaikka ethernet portti menisi. Tällöin interface pysyy aina ylhäällä. Lisäksi on helpompi yhdistää muita liitäntöjä kuten ppp ja wlanit.

  interface vlan add name=vlan100 interface=bridge-local vlan-id=100

Trunk

Tässä esimerkissä luodaan trunk interface (monta VLANia samasta interfacesta). Ensimmäiseksi teemme bridge-trunkin jonne sisälle laitamme vlanit.

 interface bridge add name=bridge-trunk

Lisätään esimerkissä vlanit 2, 3 ja 4.

/interface vlan
 add name=VLAN2 vlan-id=2 interface=bridge-trunk disabled=no
 add name=VLAN3 vlan-id=3 interface=bridge-trunk disabled=no
 add name=VLAN4 vlan-id=4 interface=bridge-trunk disabled=no

Lisätään ethernet portit jotka kuuluvat bridgeen, esimerkissä ether1

 interface bridge port add bridge=bridge-trunk interface=ether1

Luo jokaiseen VLANiin oma bridge

/interface bridge 
   add name bridge add name=bridge-vlan2
   add name bridge add name=bridge-vlan3
   add name bridge add name=bridge-vlan4

Lisätään IP-osoitteen bridgeen. IP-osoitteet kannattaa aina määrittää bridge:en sillä se ei mene koskaan alas.

/ip address 
    add address=10.10.2.1/24 interface=bridge-vlan2
    add address=10.10.3.1/24 interface=bridge-vlan3
    add address=10.10.4.1/24 interface=bridge-vlan4

Määritetään tietty portti, tiettyyn VLANiin (esimerkissä ether2 portti on VLAN3 vain VLAN3:ssa).

 interface bridge port add interface=ether2 bridge-vlan3

Lisätään wlan1:n VLAN3

 interface bridge port add interface=vlan1 bridge-vlan4

Lähteet

http://wiki.mikrotik.com/wiki/Manual:Interface/VLAN

Mainos / Advertisement: