Mainos / Advertisement:

RouterOS OSPF

Kohteesta Taisto
Loikkaa: valikkoon, hakuun

OSPF eli Open Sortest Path First on reititysprotokola IP-verkoille. OSPF:stä on myös OSPFv3 joka tarkoitettu IPv6-verkoille.

OSPF toimii niin että mainostaa naapureilleen (toisille reitittimille) - "Hei, minulla on tämä verkko täälä!", niin muut reitittimet ohjaavat paketit sinne.

Yksinkertainen konfiguraatio

Käytässämme on kolme reititintä, jotka kytketty keskenään yhteen. Ether1 kytketty hallitsemattomaan kytkimeen ja kaikki on yhteydessä toisiinsa (ping kulkee 192.168.168.2 - X.3 ja X.4 osoitteisiin). Mutta nyt on ratkaistava miten saadaan reititys toimimaan jokaiseen Mikrotikin ether2 porteissa oleviin osoitteisiin. Tämän voi toteuttaa staattisilla reiteillä, mutta usein on järkevämpää käyttää reititysprotokolaa, varsinkin kun verkko laajenee.

Mikrotik-1

  • ether1 192.168.168.2/24
  • ether2 192.168.1.1/24

Mikrotik-2

  • ether1 192.168.168.3/24
  • ether2 192.168.2.1/24

Mikrotik-3

  • ether1 192.168.168.4/24
  • ether2 192.168.3.1/24

Seuraavaksi konfiguroidaan OSPF instance kaikille Mikrotikeille

/routing ospf instance> add name=default

Lisää jokaiseen Mikrotikkiin omat verkot mitä se mainostaa, esimerkiksi:

Mikrotik-1

/routing ospf network add add network=192.168.168.0/24 area=backbone
/routing ospf network add add network=192.168.1.0/24 area=backbone

Mikrotik-2

/routing ospf network add add network=192.168.168.0/24 area=backbone
/routing ospf network add add network=192.168.2.0/24 area=backbone

Huomaathan, että pitää mainostaa samaa verkkoa mihin toinen OSPF reitin kuuluu myös ja sitten omaa verkkoa erikseen. Kun olet lisänyt verkot kaikille Mikrotikkeihin, sinun pitäisi nähdä interfacet täälä:

 /routing ospf interface print

Ja sitten naapurilaiteet

 /routing ospf neighbor print

Mainostetut reitit näet täältä

 /routing ospf route print
Mainos / Advertisement: