Mainos / Advertisement:

RouterOS DHCP

Kohteesta Taisto
Loikkaa: valikkoon, hakuun
Tämä sivu sisältää muutoksia, joita ei ole merkitty käännettäväksi.

Muut kielet:
English • ‎suomi


DHCP:llä (Dynamic Host Configuration Protocol) on helppo jakaa IP-osoitteita verkkoon. Mikrotik RouterOS:ssä on DHCP asiakas ja DHCP palvelin tuki.

DHCP Server

Varmista että sinulla on kiinteä IP-osoite määritetty Mikrotikin reitittimeen. Käytämme tässä esimerkissä 192.168.100.0/24 verkkoa. Mikrotikissä on asetettu verkon ensimmäinen IP-osoite 192.168.100.1/24. Huomaathan että Mikrotik jakaa aina DHCP poolin loppupäästä ei alkupäästä niin kuin normaalisti.

1. Luodaan DHCP pool. Tässä poolissa jaetaan esimerkissämme 192.168.100.10 ja 192.168.100.200 väliltä.

 /ip pool add name=dhcp_pool address=192.168.100.10-192.168.100.200

2. Luodaan uusi DHCP:n jako asetukset. Tähän määritetään verkon oletusyhdyskäytävä ja DNS palvelimet.

/ip dhcp-server network add address=192.168.100.0/24 gateway=192.168.100.1 netmask=24 dns-server=192.168.100.1

3. Luodaan DHCP server. Tähän määritetään mihin porttiin DHCP jaetaan ja mistä poolista (lisätään juuri äskettäin luotu pool) ja lease time (varausaika).

 /ip dhcp-server add name=dhcp-server interface=ether1 lease-time=24:00:00 address-pool=dhcp_pool


DHCP varaus

DHCP varauksella voit määrittää DHCP palvelimelle asiakaslaitteen MAC-osoitteen. Kun määritetty MAC-osoite yhdistää verkkoon jossa DHCP palvelin on, tämä antaa ennalta määritetyn IP-osoitteen kyseiselle asiakaslaitteelle.

 /ip dhcp-server lease add address=192.168.100.100 mac-address=11:22:33:44:55:66

Mikrotik ja Windows Deployment Services

Tässä esimerkki miten saa Mikrotikin DHCP:n toimimaan WDS:n kanssa. Määritä kuvankaappausten perusteella lisäasetukset DHCP palvelulle.

 Next Server = WDS-palvelimen IP-osoite
 Boot File Name = Tiedosto joka ladataan ensimmäisenä WDS palvelimesta
 DHCP Options = 060 PXEClient

Estä EI DHCP:ltä tulevat IP-osoitteet

Lisää DHCP-palvelimeen "add-arp:yes".

Ja määritä interfaceen arp=read-only

DHCP Client

DHCP Client ominaisuus mahdollistaa Mikrotikin verkkoasetusten hakemisen DHCP palvelimelta.

 /ip dhcp-client add interface=ether1 disable=no
  • Interface = Portti josta pyydetään DHCP paketit
  • disable no = Otetaan käyttöön
Mainos / Advertisement: