Mainos / Advertisement:

Cisco Router NAT/PAT

From Taisto
Jump to navigation Jump to search

NAT (Network address translation), eli suomeksi osoitemuutos. Lisätietoa http://fi.wikipedia.org/wiki/Osoitteenmuunnos

Luodan ensin NATin ulko interface eli yleensä kutsutaan WANiksi.

interface FastEthernet0/0
  ip address dhcp
  ip nat outside

Luodaan toinen interface LANiksi eli sisäverkon interfaceksi.

interface FastEthernet0/1
  ip address 192.168.1.1 255.255.255.0
  ip nat inside

Luodaan access-list eli sääntö joka sallii fa0/0:sta liikenteen eli WANista LANiin.

 access-list 7 permit any
 ip nat inside source list 7 interface FastEthernet0/0 overload

PAT- Porttiohjaus - Port Forwarding

Staattinen porttiohjaus

ip nat inside source static tcp 192.168.1.254 80 10.0.0.1 80 

Joku Johanneksen, ei hajuakaan toimiiko...

ip nat inside source static tcp 192.168.1.1 22 interface fastEthernet 0/0 22
Mainos / Advertisement: