Mainos / Advertisement:

Cisco InterVLAN reititys

From Taisto
Jump to navigation Jump to search

{{#allow-groups:sysop}} Tässä ohjeessa tehdään kuvanmukainen verkko. Kytkimen ja reitittimen välillä on yksi interface jossa on trunk. Trunk mahdollistaa useiden verkkojen (VLAN) toimimman yhdessä fyysisessä interfacessa.

14976-50a.jpg

Kytkimen konfiguraatio

Configure modessa muutetaan interface vlan 1 asetuksia

 3512xl(config)#interface vlan 1

Määritetään interface VLAN 1 IP-osoitteeksi 10.10.10.2 ja aliverkonpeitteeksi 255.255.255.0.

 3512xl(config-if)#ip address 10.10.10.2 255.255.255.0

Sulje interface vlan 1 konfiguraatio

 3512xl(config-if)#exit

Määritetään kytkimelle oletusyhdyskäytävä

 3512xl(config)#ip default-gateway 10.10.10.1
 3512xl(config)#end

Vaihdetaan inteface fastethernetin 0/1 portin mode trunkiksi.

 3512xl(config)#interface fastEthernet 0/1
 3512xl(config-if)#switchport mode trunk

Sallitaan trunkin läpi kaikki VLANit.

 3512xl(config-if)#switchport trunk allowed vlan all
 3512xl(config-if)#exit

Määritetään fastethernet 0/2 vlaniin 2.

 3512xl(config)#interface fastEthernet 0/2
 3512xl(config-if)#switchport access vlan 2
 3512xl(config-if)#spanning-tree portfast

Määritetään fastethernet 0/3 vlaniin 2.

 3512xl(config)#interface fastEthernet 0/3
 3512xl(config-if)#spanning-tree portfast
 3512xl(config-if)#^Z

Reitittimen konfiguraatio

Ota käyttöön interface FastEthernet 0/0

 c2600(config)#int fastEthernet 0/0
 c2600(config-if)#no shut
 c2600(config-if)#exit

Luodaan ali interface 0/0.1 ja määritetään IP-osoitteeksi 10.10.10.1 ja aliverkonpeitteeksi 255.255.255.0.

c2600(config)#int fastEthernet 0/0.1
c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
c2600(config-subif)#exit

Luodaan ali interface 0/0.2 ja määritetään IP-osoitteeksi 10.10.11.1 ja aliverkonpeitteeksi 255.255.255.0. Määritetään lisäksi VLAN 2.

c2600(config)#int fastEthernet 0/0.2
c2600(config-subif)#encapsulation dot1Q 2
c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit

Lähteet

http://www.cisco.com/c/en/us/support/docs/lan-switching/inter-vlan-routing/14976-50.html

Mainos / Advertisement: