Mainos / Advertisement:

PPTP-server

Kohteesta Taisto
Siirry navigaatioon Siirry hakuun
Tämä on käännetty versio sivusta PPTP-serveri, ja käännös on 100 % valmis.

{{#allow-groups:user}}

Muut kielet:
English • ‎suomi

We make a cisco 2821 router into a pptp server.

Basic info

We are using a cisco 2821 router and a client PC running Windows 8.1. The router's IOS is (C2800NM-ADVIPSERVICESK9-M), Version 12.4(15)T 8. Not that it really matters.

hostname Router

username johannes password Qwerty1
enable secret Qwerty1
interface FastEthernet0/0
 description WAN
 ip address 10.5.26.205 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 no shutdown
interface FastEthernet0/1
 description LAN
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 no shutdown

Then we setup the pptp

aaa new-model
aaa authentication login default local
aaa authentication ppp default local
aaa authorization network default local
vpdn enable
vpdn-group PPTP
 accept-dialin
  protocol pptp
  virtual-template 1
  exit

We define that we accept incoming pptp protocol vpn connections and we direct them to Virtual-Template 1

We define settings for the Virtual-Template 1 interface, such as ip-pool and encryption.

interface Virtual-template 1
 ip unnumbered FastEthernet0/1
 ip nat inside
 ip virtual-reassembly
 peer default ip address pool PPTPPOOL
 compress mppc
 ppp encrypt mppe auto
 ppp authentication ms-chap-v2


ip local pool PPTPPOOL 10.255.255.200 10.255.255.254

NAT for router:

ip nat inside source list NAT interface FastEthernet0/0 overload
ip access-list extended NAT
 deny   ip 10.0.0.0 0.0.0.255 10.255.255.0 0.0.0.255
 permit ip 10.255.255.0 0.0.0.255 any
 permit ip 10.0.0.0 0.0.0.255 any
 permit tcp any host 10.5.26.205 eq 22
 permit tcp any host 10.5.26.205 eq 1723
 permit udp any host 10.5.26.205 eq isakmp
 permit esp any host 10.5.26.205
 permit gre any host 10.5.26.205
 permit icmp any host 10.5.26.205
Mainos / Advertisement: