Mainos / Advertisement:

Sonera Viihde IPTV asetukset

Kohteesta Taisto
Loikkaa: valikkoon, hakuun
Muut kielet:
English • ‎suomi

Tässä ohjeessa neuvotaan Sonera Viihteen IPTV digiboksin käyttö toisilla palvelureitittimillä. Sonera Viihteen mukana tulee nykyisin Inteno DG301AL ja se on todettu tietoturva aukkoiseksi ja heikoksi.

Olemme todenneet että Mikrotikin reitittimellä toimii parhaiten. Asuksella on ongelmana 4:3 kuva (valkoisilla reunoilla).

Keskustele Soneran Klaanissa aiheesta ja kysy sieltä apua ohjeisiin.

Yleiset asetukset

Sinun tulee määrittää seuraavat asetukset reitittimesi asetuksiin. Soneran IPTV vaatii että verkossa on multicast VLAN 252 (IPTV) ja normaali verkkoliikenne VLAN 1 (tallennukset ja ohjelmakirjasto).

IPTV:VID 252 PRIO 0
INTERNET: VID 1 PRIO 0

IGMP Proxy Enable

VID = VLAN ID

PRIO = Priorisointi

Reititin kohtaiset asetukset

Asus DSL-N55U

https://dl.dropboxusercontent.com/u/46176780/asus_dsl-n55u_settings.jpg

Asus RT-AC56U ja Asus RT-N56U

Testattu Asus RT-N56U:lla.

http://murobbs.plaza.fi/internet-tietoturva-ja-muu-tietoliikenne/685233-sonera-kotitv-iptv-75.html#post1714391870

http://murobbs.muropaketti.com/threads/sonera-kotitv-iptv.685233/page-77#post-1709453694

LAN -> IPTV-tabi
Select ISP profile: Manual
Internet VID tyhjä PRIO 0
LAN port 4 VID 252 PRIO 0
LAN port 3 VID tyhjä PRIO 0

Special applications:
Use DHCP routes Microsoft
Enable multicast routing (IGMP Proxy) Enable
Enable efficient multicast forwarding (IGMP Snooping) Enable
UDP Proxy (Udpxy) 0

Linux

Igmpproxy

Asus RT-N66U

http://murobbs.muropaketti.com/threads/sonera-kotitv-iptv.685233/page-76#post-1709438782

RouterOS

RouterOS_IPTV

OpenWRT

http://klaani.sonera.fi/t5/Tekninen-keskustelu/Sonera-Viihde-muulla-kuin-Soneran-palvelureitittimell%C3%A4/m-p/99674/highlight/false#M1354

/etc/network/interfaces

onfig interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd05:643b:6a84::/48'

config interface 'lan'
    option force_link '1'
    option type 'bridge'
    option igmp_snooping '1'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ifname 'eth0.1'
    option macaddr '00:01:02:03:04:05'

config interface 'lan_iptv'
    option proto static
    option ifname eth0.3
    option ipaddr 192.168.2.1
    option netmask 255.255.255.0

config interface 'wan_iptv'
    option proto 'dhcp'
    option ifname 'ptm0.252'
        option defaultroute 0

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '5 6t'

config interface 'eth_wan'
    option proto 'dhcp'
    option ifname 'eth0.2'
    option macaddr 'xx:xx:xx:xx:xx:C8'

config interface 'wan'
    option proto 'dhcp'
    option ifname 'ptm0'
    option service 'Data'
    option wan_instance '3.1.2.1'
    option macaddr 'xx:xx:xx:xx:xx:C9'
    
config vdsl 'dsl'
    option annex 'b'
    option firmware '/lib/firmware/vdsl_b.bin'
    option tone 'bv'
    option xfer_mode 'ptm'

config atm-bridge
    option unit '0'
    option atmdev '0'
    option encaps 'llc'
    option payload 'bridged'
    option vci '33'
    option vpi '0'

config switch_vlan
    option device 'switch0'
    option vlan '3'
    option ifname 'eth0.3'
    option ports '4 6t'

/etc/config/igmpproxy

config igmpproxy
    option quickleave 1

config phyint
    option network wan_iptv
    option direction upstream
    list altnet 0.0.0.0/0

config phyint
    option network lan_iptv
    option direction downstream

/etc/config/firewall

config zone
    option name        lan_iptv
    list   network        'lan_iptv'
    option input        ACCEPT
    option output        ACCEPT
    option forward        ACCEPT

config zone
    option name        wan
    list   network        'wan'
    list   network        'wan6'
    option input        REJECT
    option output        ACCEPT
    option forward        REJECT
    option masq        1
    option mtu_fix        1

config zone
    option name        wan_iptv
    list   network        'wan_iptv'
    option input        REJECT
    option output        ACCEPT
    option forward        REJECT
    option masq        1

config forwarding
    option src            lan
    option dest        wan

config forwarding
    option src            lan_iptv
    option dest        wan_iptv

config forwarding
    option src            lan_iptv
    option dest        wan

config rule
        option src      wan_iptv
        option proto    igmp
        option target   ACCEPT

config rule
        option src      wan_iptv
        option proto    udp
        option dest     lan_iptv
        option dest_ip  224.0.0.0/4
        option target   ACCEPT
        option family   ipv4

Lähde: https://forum.openwrt.org/viewtopic.php?pid=266536#p266536

Telewell

http://murobbs.muropaketti.com/threads/sonera-kotitv-iptv.685233/page-82#post-1710111932

TW-EA510

https://telewell.fi/files/tw-eav510v1_sonera_viihde_ethernet-liittyma.pdf

https://telewell.fi/files/TW-EA510_v3c_sonera_iptv.pdf

https://telewell.fi/files/sonera_viihde_ja_tw-eav510v6.pdf

Ei toimivat laitteet

Sonera Viihde IPTV kanavat tietokoneelle

Tämä vaatii siis reitittimen joka tulee Multicast:iä ja IGMP liikennettä. Toimii vain Soneran verkossa (toki tunnelilla toimii ulospäinkin).

Lataa ja asenna VLC Player. Kopio alla olevat osoitteet ja tallenna se iptv.m3u tiedostoksi. Avaa tiedosto VLC Player:illä.

Androidille: https://play.google.com/store/apps/details?id=org.videolan.vlc.betav7neon

 #EXTM3U
 #EXTINF:0,YLE1
 udp://@239.16.116.1:5555
 #EXTINF:0,YLE2
 udp://@239.16.116.2:5555
 #EXTINF:0,MTV3
 udp://@239.16.116.3:5555
 #EXTINF:0,Nelonen
 udp://@239.16.116.4:5555
 #EXTINF:0,YLE FEM
 udp://@239.16.116.5:5555
 #EXTINF:0,Sub
 udp://@239.16.116.6:5555
 #EXTINF:0,YLE Teema
 udp://@239.16.116.7:5555
 #EXTINF:0,Liv
 udp://@239.16.116.8:5555
 #EXTINF:0,TV5
 udp://@239.16.116.13:5555
 #EXTINF:0,Kutonen
 udp://@239.16.116.10:5555
 #EXTINF:0,FOX TV
 udp://@239.16.116.12:5555
 #EXTINF:0,JIM
 udp://@239.16.116.14:5555
 #EXTINF:0,AVA
 udp://@239.16.117.145:5555
 #EXTINF:0,Hero
 udp://@239.16.117.143:5555
 #EXTINF:0,TV7
 udp://@239.16.116.11:5555
 #EXTINF:0,YLE1 HD
 udp://@239.16.117.146:5555
 #EXTINF:0,YLE2 HD
 udp://@239.16.117.147:5555
 #EXTINF:0,YLE FEM HD
 udp://@239.16.117.148:5555
 #EXTINF:0,YLE TEEMA HD
 udp://@239.16.117.149:5555

Muissa kanavissa on salaus, joten niitä ei tahdo saada auki...

Lähteet

http://klaani.sonera.fi/t5/Palstan-arkisto/Koti-TV-n-k%C3%A4ytt%C3%B6-muulla-reitittimell%C3%A4-kuin-Thomson-TG784/m-p/15997#M15980

https://www.dvdplaza.fi/forums/showthread.php/80550-Sonera-KotiTV-IPTV-palvelu/page2

Mainos / Advertisement: